CVE-2026-88041
High
Description
Incomplete cleanup vulnerability in Apache Tomcat allowed an trailer information from a previous request to leak into a subsequent request. This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.26, from 10.1.27 through 10.1.60, from 9.0.92 through 9.0.122. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Tomcat
PublishedOct 20, 2026
First seenOct 20, 2026
Weakness typeCWE-459CWE-459
How to fix
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Tomcat | 11.0.0-M23 ≤ v ≤ 11.0.26, 10.1.27 ≤ v ≤ 10.1.60, 9.0.92 ≤ v ≤ 9.0.122 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.