CVE-2026-88920
Critical
Description
An authentication bypass in the DOM security processor in Apache WSS4J allows unauthenticated remote attackers to forge authenticated SOAP messages via a crafted unsigned SAML sender-vouches assertion containing an attacker-controlled key. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Wss4j
PublishedSep 30, 2026
First seenSep 30, 2026
Weakness typeCWE-287Improper authentication
How to fix
Update
- apache wss4j2.4.4, 3.0.6, 4.0.2 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache wss4j | v < 2.4.4, 3.0.0 ≤ v < 3.0.6, 4.0.0 ≤ v < 4.0.2 | 2.4.4, 3.0.6, 4.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.