CVE-2026-90797
High
Description
An unlimited gzip decompression routine in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows any remote client to cause a denial of service via memory exhaustion. Users are recommended to upgrade to version 3.5.3, which fixes this issue.
SeverityHigh
CVSS7.7
Exploit probability—
ProductApache CouchDB
PublishedOct 20, 2026
First seenOct 20, 2026
Weakness typeCWE-409CWE-409
How to fix
Update
- Apache Software Foundation Apache CouchDB3.5.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Software Foundation Apache CouchDB | v < 3.5.3 | 3.5.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.