CVE-2026-90799
Low
Description
Unsafe binary deserialisation in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows an authenticated user to cause a denial of service via memory exhaustion. Users are recommended to upgrade to version 3.5.3, which fixes this issue.
SeverityLow
CVSS1.3
Exploit probability—
ProductApache CouchDB
PublishedOct 20, 2026
First seenOct 20, 2026
Weakness typeCWE-502Deserialization of untrusted data
How to fix
Update
- Apache Software Foundation Apache CouchDB3.5.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Software Foundation Apache CouchDB | v < 3.5.3 | 3.5.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.