CVE-2026-91999

Medium

Description

Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Sling XSS. This issue affects Apache Sling XSS: before 2.4.12. Users are recommended to upgrade to version 2.4.12, which fixes the issue.

SeverityMedium
CVSS6.1
Exploit probability—
ProductApache Sling Xss Protection Api
PublishedSep 23, 2026
First seenSep 23, 2026

How to fix

Update
  • apache sling_xss_protection_api2.4.12 or later

Affected products

ProductAffected versionsFixed in
apache sling_xss_protection_apiv < 2.4.122.4.12

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-91999 · Apache Sling Xss Protection Api · Dark Radar