CVE-2026-92414
Description
: Session Fixation / Session Reuse across Users vulnerability in Apache Jackrabbit. Jackrabbit WebDAV server attaches a cached authenticated session on any Lock-Token/TransactionId/SubscriptionId/If-header field token match with no credential check. This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.
How to fix
- apache jackrabbit2.20.18, 2.22.5, 2.23.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache jackrabbit | 2.20.0 ≤ v < 2.20.18, 2.22.0 ≤ v < 2.22.5, 2.23.0 ≤ v < 2.23.6 | 2.20.18, 2.22.5, 2.23.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.