CVE-2026-9256

High

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when a rewrite directive uses a regex pattern with distinct, overlapping Perl-Compatible Regular Expression (PCRE) captures (for example, ^/((.*))$) and a replacement string that references multiple such captures (for example, $1$2) in a redirect or arguments context. An unauthenticated attacker along with conditions beyond their control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

SeverityHigh
CVSS8.1
Exploit probability—
ProductF5 Nginx Open Source
PublishedMay 22, 2026
First seenMay 22, 2026
Weakness typeCWE-122CWE-122

How to fix

Affected products

ProductAffected versionsFixed in
f5 nginx_open_source0.1.17 ≤ v ≤ 0.9.7, 1.0.0 ≤ v < 1.30.2, 1.31.01.30.2
f5 nginx_plusr33 ≤ v < r36, 37.0.0.1, r32, r36r36
f5 dos4.3.0 ≤ v ≤ 4.7.0, 4.9.0—
f5 nginx_gateway_fabric1.3.0 ≤ v ≤ 1.6.2, 2.0.0 ≤ v < 2.6.22.6.2
f5 nginx_ingress_controller3.5.0 ≤ v ≤ 3.7.2, 4.0.0 ≤ v ≤ 4.0.1, 5.0.0 ≤ v < 5.4.35.4.3
f5 nginx_instance_manager2.17.0 ≤ v < 2.22.12.22.1
f5 waf4.10.0 ≤ v ≤ 4.16.0, 5.2.0 ≤ v ≤ 5.8.0, 5.9.0 ≤ v ≤ 5.13.0—
redhat discoveryNo range specified—
redhat hardened_imagesNo range specified—
redhat update_infrastructure5.0 ≤ v < 5.25.2
debian debian_linux11.0—
redhat enterprise_linux8.0, 9.0, 10.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.