CVE-2026-93337

High

Description

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains an improper input validation vulnerability that allows local users with VPN connection creation permissions to inject arbitrary pppd directives by supplying mru or mtu property values containing trailing non-numeric content after a valid integer. Attackers can exploit the verbatim write of unvalidated strings into the pppd options file via write_config_option() to inject the plugin directive, causing the privileged pppd process to load an attacker-controlled shared object and achieve arbitrary code execution as root.

SeverityHigh
CVSS7.8
Exploit probability—
ProductNetworkManager-l2tp
PublishedSep 17, 2026
First seenSep 17, 2026
Weakness typeCWE-88CWE-88

How to fix

Affected products

ProductAffected versionsFixed in
nm-l2tp NetworkManager-l2tpv ≤ 1.52.4—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.