CVE-2026-94220

Low

Description

Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX. An attacker who can get a user to click a crafted link may cause that user's browser session on a protected route to be established under the attacker's identity instead of their own. Any work the user then performs in that session, including uploads, form submissions, and account bindings, lands in the attacker's account. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

SeverityLow
CVSS2.1
Exploit probability—
ProductApache APISIX
PublishedOct 1, 2026
First seenOct 1, 2026

How to fix

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache APISIX3.17.0 ≤ v ≤ 3.18.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.