CVE-2026-94635

High

Description

Allocation of resources without limits or throttling, Improper handling of length parameter inconsistency vulnerability in Apache Thrift Lua bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

SeverityHigh
CVSS8.7
Exploit probability—
ProductApache Thrift
PublishedOct 2, 2026
First seenOct 2, 2026

How to fix

Update
  • Apache Software Foundation Apache Thrift0.25.0 or later

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache Thriftv < 0.25.00.25.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.