CVE-2026-94637

High

Description

Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

SeverityHigh
CVSS8.2
Exploit probability—
ProductMicrosoft Azl3 Kata-containers-cc
PublishedOct 2, 2026
First seenOct 2, 2026
Weakness typeCWE-409CWE-409

How to fix

Affected products

ProductAffected versionsFixed in
microsoft azl3_kata-containers-cc_3.15.0.aks0-21No range specified—
microsoft azl3_telegraf_1.31.0-33No range specified—
microsoft azl3_vitess_19.0.4-14No range specified—
microsoft azl3_kata-containers-cc_3.15.0.aks0-23No range specified—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.