CVE-2026-95624

Medium

Description

The Tauri updater plugin's 'check' IPC command accepts an allowDowngrades boolean parameter directly from frontend JavaScript code. When set to true, it replaces the version comparator from "update must be newer" to "update must be different." Because the default permission set grants allow-check to the webview, any XSS in the app frontend can invoke this command and bypass the only anti-rollback protection the updater offers. Combined with another bug, this enables downgrade attacks without even needing to fake a higher version number.

SeverityMedium
CVSS6.8
Exploit probability—
ProductTauri-plugin-updater
PublishedSep 22, 2026
First seenSep 22, 2026

How to fix

Affected products

ProductAffected versionsFixed in
Tauri tauri-plugin-updater2.8.0 ≤ v < 2.12.02.12.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.