CVE-2026-97380

High

Description

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the GRANT PROXY statement treats an IDENTIFIED clause with an empty password as though authentication were not specified, causing it to check the wrong grantor privileges. A low-privileged attacker who can name another account can exploit this authorization error to set that account's password. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

SeverityHigh
CVSS8.8
Exploit probability—
ProductMariadb
PublishedOct 16, 2026
First seenOct 16, 2026

How to fix

Update
  • mariadb mariadb10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3 or later

Affected products

ProductAffected versionsFixed in
mariadb mariadb10.6.1 ≤ v < 10.6.28, 10.11.1 ≤ v < 10.11.19, 11.4.1 ≤ v < 11.4.13, 11.8.1 ≤ v < 11.8.9, 12.3.1 ≤ v < 12.3.3, 13.0.110.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.